[JIRA] (SLF4J-405) Android app with transitive (unrestricted?) dependencies from slf4j does not compile under Android Studio

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[JIRA] (SLF4J-405) Android app with transitive (unrestricted?) dependencies from slf4j does not compile under Android Studio

JIRA noreply-jira@qos.ch

     [ https://jira.qos.ch/browse/SLF4J-405?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ceki Gülcü resolved SLF4J-405.
------------------------------
    Resolution: Cannot Reproduce

Please describe the problem in a more reproducible way. Also note that as of version 1.8.x, slf4j-android module no longer ships with SLF4J.

> Android app with transitive (unrestricted?) dependencies from slf4j does not compile under Android Studio
> ----------------------------------------------------------------------------------------------------------
>
>                 Key: SLF4J-405
>                 URL: https://jira.qos.ch/browse/SLF4J-405
>             Project: SLF4J
>          Issue Type: Bug
>          Components: Core API
>    Affects Versions: 1.8.0
>         Environment: Windows 10
> Android Studio 2.3 
>            Reporter: Lev
>            Assignee: SLF4J developers list
>
> I have a huge Android (Gradle) project which had been compiling just fine till 07.04.2017 (yesterday) under Android Studio 2.3.
> Now I have
>     *Error:Execution failed for task ':app:compileReleaseJavaWithJavac'.*
> *> Could not expand ZIP 'C:\Users\1\.gradle\caches\modules-2\files-2.1\org.slf4j\slf4j-api\1.8.0-alpha0\3745fbc3ca51456387cf068d66442513898a42f1\slf4j-api-1.8.0-alpha0.jar'.*
> I am not using slf4j-api directly, but I suppose that some of .aar libs included in my project (or Andoid Studio !?) do that and probably on the "unrestricted" basis, i.e. as:
>      *compile 'org.slf4j:slf4j-api:1.+'*
> So, there was no problem before 07.04.2017, but yesterday your have updated your https://www.slf4j.org/dist/ with [slf4j-1.8.0-alpha0|https://www.slf4j.org/dist/slf4j-1.8.0-alpha0.zip] and I have got problems.
> Would you be so kind to remove this version from your repo, because I am using Java 8 in my project and therefore I can't restrict himself with using of slf4j-1.7.x by means of gradle command. More over I have no idea which of .aar libraries in my project uses slf4j by inappropriate way.



--
This message was sent by Atlassian JIRA
(v7.3.1#73012)
_______________________________________________
slf4j-dev mailing list
[hidden email]
http://mailman.qos.ch/mailman/listinfo/slf4j-dev
Loading...